SharePointCommunity
Die deutschsprachige Community für SharePoint, Microsoft 365, Teams, Yammer und mit Azure

Sponsored by

Willkommen im Forum Archiv.
Einträge sind hier nicht mehr möglich, aber der Bestand von 12 Jahren SharePoint-Wissen ist hier recherchierbar.


SharePoint und HostHeader

Unbeantwortet Dieser Beitrag hat 5 Antworten

Ohne Rang
168 Beiträge
niceoldlady erstellt 10 Mai 2010 15:30
SchlechtSchlechtIn OrdnungIn OrdnungDurchschnittDurchschnittGutGutSehr gutSehr gut

Hi,

ich habe schon viele Ansätze aus dem netz versucht, aber leider war nichts dabei was zu meiner Zufriedenheit funktioniert hat.

Ich suche folgendes: Ich habe mehrere WebAnwendungen auf verschiedenen Ports, z.B. 8080 und 8081. Beide haben natürlich eigene Datenbanken und müssen auch zwingend auf verschiedenen laufen.

Mein Problem: Die Anwendungen müssen von außen erreichbar sein und zwar nur über Port 80. Also zum beispiel port8080.mybusiness.de und port8081.mybusiness.com. Wie kann ich das erreichen?

Versuch1: WebAnwendung erweitern auf eine neue IIS- WebSeite auf Port 80 mit Hostheader. Hat genau so funktioniert wie gewollt. Leider nicht mehr mit der zweiten danach. Wieso auch immer.

Versuch2: WebAnwendung nicht erweitern und über Alternative zugriffsordnungen einen HostHeader einrichten und diesen danach im IIS registrieren. Aber auch das hat nur für eine WebAnwendung geklappt.

Könnt ihr vielleicht weiter helfen?

MfG

Alle Antworten

Ohne Rang
643 Beiträge
Henning Eiben Als Antwort am 11 Mai 2010 09:29
SchlechtSchlechtIn OrdnungIn OrdnungDurchschnittDurchschnittGutGutSehr gutSehr gut

Also eigentlich muss der erste Punkt funktionieren. So haben wir auch eine ganze Reihe von Webs auf einem Server zugänglich gemacht. Wenn du beim erweitern des Webs eine Zone auswählst, dann wird automatische die Alternative Zugriffsordnung für den Hostheader erstellt.

Henning Eiben
busitec.de

Ohne Rang
168 Beiträge
niceoldlady Als Antwort am 11 Mai 2010 09:33
SchlechtSchlechtIn OrdnungIn OrdnungDurchschnittDurchschnittGutGutSehr gutSehr gut

hmm, ich mach das mal nochmal und schreibe genau alle schritte auf die ich gemacht habe.

1. Erstellen einer WebAnwendung auf port 80 ohne Seiten Sammlung und ohne HostHeader mit standard Einstellungen (NTLM, no anonymous usw)

2. Erstellen einer WebAnwendung auf port 8080 mit Seitensammlung. Gleiche Einstellungen wie 1

3. Erstellen einer WebAnwendung auf port 8081 mit Seitensammlung. Gleiche Einstellungen wie 1 und 2

4. Testen der Einstellungen: Beide WebAnwendungen sind auf ihren Ports mit den Seitensammlungen erreichbar.

5. Unter Webanwendung Erweitern wähle ich als erstes die WebAnwendung auf 8080 aus und wähle (kann cih nur) neue IIS- Seite erstellen und nehem Port 80 mit HoseHeader in der Zone Intranet.

6. Das gleiche wie bei 5 nur mit anderem HoastHeader und der WebAnwendung auf 8081

7. Im IIS habe ich jetzt 4 neue Webseiten. 2x WebAnwendung und 2x die neuen zwecks Erweiterung

8. die WebAnwendung auf port 8080 ist über den HostHeader von 5 erreichbar (http://spswyxdev)

9. die WebAnwendung auf port 8081 ist nicht über den HostHeader von 6 erreichbar, auch nicht nach einem IIS- Reset. Ich bekomme ein "Internet Explorer cannot display the webpage" (http://sptest)

Was fehlt oder ist falsch? Ich versteh nicht wieso die erste erreichbar ist, die zweite aber nicht.

Ohne Rang
168 Beiträge
niceoldlady Als Antwort am 17 Mai 2010 09:06
SchlechtSchlechtIn OrdnungIn OrdnungDurchschnittDurchschnittGutGutSehr gutSehr gut

hat keiner noch ne idee?

Ohne Rang
643 Beiträge
Henning Eiben Als Antwort am 18 Mai 2010 09:23
SchlechtSchlechtIn OrdnungIn OrdnungDurchschnittDurchschnittGutGutSehr gutSehr gut

Wieso machst du eigentlich den ersten Schritt, wenn du dort keine Website-Collection anlegst?

Hast du im IE diese Option "kurze Fehlermeldungen" aktiviert oder hast du auch einen HTTP-Code für den Fehler?

Ist der Hostname http://sptest auch im DNS richtig eingerichtet? Löst der Name auf die richtige IP-Adresse auf (mal mit nslookup sptest probieren)?

Henning Eiben
busitec.de

Ohne Rang
168 Beiträge
niceoldlady Als Antwort am 18 Mai 2010 10:03
SchlechtSchlechtIn OrdnungIn OrdnungDurchschnittDurchschnittGutGutSehr gutSehr gut

ich habs schon hinbekommen: einfach 2 webanwendungen mit hostheader direkt auf port 80 legen und dann beim admin vorkrichen udn dns einträge erbetteln :)

 

mfg