SharePointCommunity
Die deutschsprachige Community für SharePoint, Microsoft 365, Teams, Yammer und mit Azure

Sponsored by

Willkommen im Forum Archiv.
Einträge sind hier nicht mehr möglich, aber der Bestand von 12 Jahren SharePoint-Wissen ist hier recherchierbar.


Fehlermeldung nach bedingter Formatierung "Webpart kann nicht angezeigt werden..."

Geprüfte Antwort Dieser Beitrag hat 3 Antworten

Ohne Rang
367 Beiträge
Tiac erstellt 15 Jul 2013 07:48
SchlechtSchlechtIn OrdnungIn OrdnungDurchschnittDurchschnittGutGutSehr gutSehr gut

Hallo Communitiy,

ich habe im Sharepoint Designer bedingte Formatierungen für Listen vorgenommen. Um genau zu sein, habe ich einige Spalte mit Farben angepasst. Das hat auch alle super funktioniert.

Nach ein paar Tage kam dann diese Fehlermeldung: "Dieses Webpart kann nicht angezeigt werden. Öffnen Sie diese Webseite in einem mit Microsoft SharePoint Foundation kompatiblen HTML-Editor, z. B. in Microsoft SharePoint Designer, um dieses Problem zu behandeln. Falls das Problem weiterhin besteht, wenden Sie sich an Ihren Webserveradministrator."

Über die Korrelations-ID bekam ich dann folgenden Meldung heraus, mit der ich leider nichts anfangen kann:

Name=Request (GET:http://[Server]/[Sites]/[Subsites]/[Lists]/[Name der Liste]/AllItems.aspx) 

Name=Request (GET:http://Server]/[Sites]/[Subsites]/[Lists]/[Name der Liste]/AllItems.aspx)

Leaving Monitored Scope (PostResolveRequestCacheHandler). Ausführungszeit=13,264

Error while executing web part: System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.     bei System.Xml.Xsl.XslCompiledTransform.Load(MethodInfo executeMethod, Byte[] queryData, Type[] earlyBoundTypes)     bei Microsoft.Xslt.STransform.GetCompiledTransform()     bei Microsoft.SharePoint.WebPartPages.BaseXsltListWebPart.LoadXslCompiledTransform(WSSXmlUrlResolver someXmlResolver)     bei Microsoft.SharePoint.WebPartPages.DataFormWebPart.GetXslCompiledTransform()     bei Microsoft.SharePoint.WebPartPages.DataFormWebPart.PrepareAndPerformTransform(Boolean bDeferExecuteTransform)

Leaving Monitored Scope (Request (GET:http://[Server]/[Sites]/[Subsites]/[Lists]/[Name der Liste]/AllItems.aspx)). Ausführungszeit=79,769

 

Hat vielleicht jemand von euch eine Idee, warum ich plötzlich diese Fehlermeldung habe und was ich tun kann, damit die bedingte Formatierung wieder angezeigt wird?

 

Alle Antworten

Ohne Rang
19231 Beiträge
Andi Fandrich Als Antwort am 16 Jul 2013 08:40
SchlechtSchlechtIn OrdnungIn OrdnungDurchschnittDurchschnittGutGutSehr gutSehr gut

Hört sich stark danach an: http://blogs.evocom.de/af/archive/2013/07/11/vorsicht-mit-kb2844286.aspx

Das scheint langsam zu einem ernsthaften Problem zu werden...

Viele Grüße
Andi
af @ evocom de
Blog
Ohne Rang
367 Beiträge
Tiac Als Antwort am 16 Jul 2013 13:59
SchlechtSchlechtIn OrdnungIn OrdnungDurchschnittDurchschnittGutGutSehr gutSehr gut

Bei uns hat es daran gelegen. Das Update wurde eben entfernt und schon funktioniert unsere bedingte Formatierung wieder.

Perfekt, Dankeschön.

Grüße

Tiac

Ohne Rang
1 Beiträge
Markus Hiller Als Antwort am 5 Aug 2013 16:52
SchlechtSchlechtIn OrdnungIn OrdnungDurchschnittDurchschnittGutGutSehr gutSehr gut

Es existiert ein Bugfix dafür. Habe es heute getestet, der Fehler war nach der Installation des Fixes und anschließendem reboot behoben.

Hier erhältlich.

Viele Grüße


Markus