SharePointCommunity
Die deutschsprachige Community für SharePoint, Office 365 und mit Azure

Berechtigungen mit URL %20 und ohne

bewertet von 0 Usern
Nicht beantwortet Dieser Beitrag hat 0 Geprüfte Antworten | 3 Antworten | 2 Followers

Top-100-Beitragsschreiber
122 Beiträge
Franke079 erstellt in 9 Sep 2016 15:25

Hallo Zusammen,

 

folgendes Phänomen habe ich, vielleicht ist es auch nur ein Bug.

Ich habe eine Website, wo auf der linken Seite Dokumentenbibliotheken in der Schnellstartleiste zu sehen sind. Nun habe ich einen User, welcher nur eine Bibliothek sehen darf, soweit so gut.

Jedoch sieht er auf der linken Seite (Schnellstartleiste) alle Bibliotheken , wo in der URL %20 vorkommt, alle wo in der URL kein %20 steht ist korrekt, werden ihm nicht angezeigt.

Ist das so richtig? 

Alle Antworten

Top-10-Beitragsschreiber
Männlich
18.168 Beiträge

Das hat mit %20 definitiv überhaupt nichts zu tun. Das %20 deutet aber darauf hin, daß diese Links jemand aus dem Browser kopiert und manuell eingefügt hat. Bei manuell angelegten Links greift aber niemals das Security Trimming, d.h. sie werden immer für jeden angezeigt.

Viele Grüße
Andi
af @ evocom de
Blog
Top-500-Beitragsschreiber
Weiblich
43 Beiträge

Mein Verständnis bezüglich der %20 war immer, dass dieses die Leerzeichen sind, welche bei Anlage von Liste/Bibliothek entstehen. Ist ein Leerzeichen im Titel tauchen die %20 auf, ist keine Leerzeichen definiert - dann halt keine Anzeige

Example: 'Tolle Liste' ergibt 'urlanfang/Tolle%20Liste'

Hast du mal geschaut, ob es eventuell Zufall ist, dass bei den Bibliotheken die nicht in der Schnellstartleiste angezeigt werden, hier gar nicht zur Anzeige in der Schnellstartleiste definiert sind (Bibliothekseinstellungen)?

 

Top-10-Beitragsschreiber
Männlich
18.168 Beiträge

Nur zur Erklärung: wenn man eine Liste mit Leerzeichen im Namen anlegt, dann hat die Adresse später auch ein Leerzeichen. In der Adressleiste des Browsers wird das dann als %20 kodiert. Bei modernen Websites und modernen Browsern und Verwendung von UTF-8 ist das zwar nicht mehr notwendig, aber es wird trotzdem oft gemacht. Man kann das %20 aber gefahrlos durch ein Leerzeichen ersetzen.

Viele Grüße
Andi
af @ evocom de
Blog
Seite 1 von 1 (4 Elemente) | RSS