SharePointCommunity
Die deutschsprachige Community für SharePoint, Microsoft 365, Teams, Yammer und mit Azure

Berechtigungsworkflow bricht mit einem Fehler ab

bewertet von 0 Usern
Nicht beantwortet Dieser Beitrag hat 0 Geprüfte Antworten | 6 Antworten | 3 Followers

Top-500-Beitragsschreiber
36 Beiträge
Wolfgang erstellt in 13 Mrz 2019 20:54

Hallo zusammen,

wir haben ein merkwürdiges verhalten im SharePoint.

Ich habe einen Workflow gebaut in dem Kollegen Dokumente ablegen. Über einen Workflow lass ich am Ende eines Prozesses die Berechtigung ändern (Identitätswechselschritt). Das klappt auch für die Nutzer in Deutschland ohne Probleme. Bei unseren Kollegen in CZ läuft der Workflow auf einen Fehler und zwar genau bei diesem Identitätswechselschritt und beim ändern der Berechtigung. 

Wir haben mit einem Testuser bereit (fast) alles probiert.

1. Testuser als Administrator und Besitzer eingetragen um Berechtigungsprobleme auszuschließen.

2. Testuser in die "deutsche" AD-Gruppe verschoben.

3. Testuser aus verschiedenen Netzen getestet.

4. Mit und ohne Sonderzeichen getestet.

Wir sind mit unserem Latein am Ende. GPOs sind es wohl auch nicht. Kann es an der Sprache liegen. Die Websitesammlung ist in deutsch anlegt, alternative Sprache Englisch.

Hat jemand eine Idee an was es noch liegen könnte? Kann die Sprache des Browsers Einfluss auf den Workflow haben?

Ich bin für jeden Tip dankbar :-).

Viele Grüße

Wolfgang

Alle Antworten

Top-10-Beitragsschreiber
618 Beiträge

Auf welchen Fehler läuft er denn? Hast du mal ein paar Informationen in die Workflow History ausgegeben, um etwas mehr darüber zu erfahren, was ggf. auch vorher passiert?

Grüße

Olaf

 

Top-500-Beitragsschreiber
36 Beiträge

Hallo Olaf,

 

erstmal vielen Dank für die schnelle Rückantwort. Ich hab ziemlich viel in der History ausgeben lassen und kann gut nachvollziehen wo der Fehler auftritt. Wenn die Berechtigung für das Dokument neu gesetzt wird, dann bricht er mit dem Fehler ab. Im Log steht folgendes:

Medium Some of permissions are missing (Bearbeiten) da.....

Unexpected WinWF Internal Error, terminaiting workflow Id' 7.....

Unexpected Microsoft.SharePoint.SPException: Permission level cannot be found.     at Microsoft.SharePoint.SPRoleDefinitionCollection.get Item(String)

Wäre also vielleicht doch ein Hinweis auf die Sprache ... oder?

Kannst du damit was anfangen?

 

Beste Grüße

Wolfgang

 

 

Top-25-Beitragsschreiber
446 Beiträge
Derby Als Antwort auf 14 Mrz 2019 13:42

Wolfgang:

Medium Some of permissions are missing (Bearbeiten) da.....

Unexpected WinWF Internal Error, terminaiting workflow Id' 7.....

Unexpected Microsoft.SharePoint.SPException: Permission level cannot be found.     at Microsoft.SharePoint.SPRoleDefinitionCollection.get Item(String)

 

are missing (Bearbeiten) 

Permission level cannot be found. 

 

Da klemmt der Schuh. Hab ihr was an den Berechtigungsstufen oder nach dem Erstellen des WF die Sprache geändert?

Top-500-Beitragsschreiber
36 Beiträge

Die Sprache ist standardmäßig auf "Deutsch" eingestellt und als alternative Sprache ist "Englisch" angehakt. Die Standardsprache wurde nicht geändert ob nach der Erstellung des WF Englisch als Zusatz angehakt wurde oder ob das schon vorher drinnen war kann ich nicht sagen ...

Der Workflow läuft für die deutschen Nutzer auch 1a durch nur die Kollegen in CZ haben das Problem ... da würde das mit der Sprache evtl. passen.

Meinst du den WF neu zu schreiben würde helfen - mit den aktuellen Einstellungen? 

Gruß

Wolfgang

 

Top-500-Beitragsschreiber
36 Beiträge

Also das wars ... den Haken bei Englisch raus und es läuft. :-)

Vielen Dank für die schnellen und kompetenten Rückmeldungen. Ihr habt mir sehr geholfen.

Beste Grüße

Wolfgang

Top-500-Beitragsschreiber
36 Beiträge

Also das wars ... den Haken bei Englisch raus und es läuft. :-)

Vielen Dank für die schnellen und kompetenten Rückmeldungen. Ihr habt mir sehr geholfen.

Beste Grüße

Wolfgang

Seite 1 von 1 (7 Elemente) | RSS