SharePointCommunity
Die deutschsprachige Community für SharePoint, Microsoft 365, Teams, Yammer und mit Azure

Problem Aktualisierung mehrzeiliges Textfeld im SharePoint Designer Workflow 2010

bewertet von 0 Usern
Nicht beantwortet Dieser Beitrag hat 0 Geprüfte Antworten | 0 Antworten | 1 Follower

Top-500-Beitragsschreiber
41 Beiträge
Schmidt Mathias erstellt in 7 Mrz 2019 10:33

Hallo Community,

ich habe ein Problem bei der Aktualisierung eine Mehrzeiligen Textfeldes(war mal einzeiliges Textfeld) im SharePoint Designer Workflow 2010.

Die Konstellation ist so, dass der Workflow dieses Feld aus dem aktuellen Element mit Daten aus einer Nachschlagespalte(Als Zeichenfolge) befüllt.

Dies erfolgt auf einer Liste, welche mittlerweile ca 8000 Elemente enthält.

Der Workflow selbst funktioniert bei fast allen Elementen. Er scheitert bei genau 45 Elementen an diesen Textfeld.

Als Fehler meldet er mit nur:

Das Element konnte vom Workflow nicht aktualisiert werden, möglicherweise weil mindestens eine Spalte des Elements einen anderen Informationstyp erfordert.

Ich habe dann etwas mit den Daten herumgespielt und festgestellt, dass dieser Fehler eintritt, sobald die länge des Strings 300 Zeichen übersteigt. Bei weniger Zeichen(auch 299) laufen auch die 45 fehlerhaften Elemente ohne Probleme durch.

Im ULS Log habe ich auch bei ausführlicher Protokollierung keinen tieferen Eintrag als oben genannt gefunden.

Da es sich um ein vormals einzeiliges Textfeld handelte, dachte ich das sein das Problem. Ich habe die Spalte daeshalb gelöscht und nochmals unter dem selben Namen erstellt. Dies brachte leider nicht den gewünschten erfolg. 

Ich habe zum test deshalb mal eine zusätzliche mehrzeilige Textspalte erstellt. Bei der Aktualisierung dieser mittels des Workflow werden auch mehr als 300 Zeichen übernommen. Es laufen dann alle Elemente problemlos durch.

Fehlerhafte Textspalte und funktionierende Textspalte sind in ihren Einstellungen identisch.(auch per PowerShell geprüft)

 

Ich habe anschließen die fehlerhafte Spalte mal per PowerShell mit mehr Zeichen befüllt. Darüber ging es dann ohne Probleme.

 

Ist ein solches Problem bekannt? Kann es an der Änderung des Typs liegen? Wenn ja warum hilft dann selbst neu erstellen nicht?

 

Die Testspalte als neue Spalte zu nutzen ist leider keine Option. Ich benötige den Namen und den Internen Namen der alten Spalte.

Seite 1 von 1 (1 Elemente) | RSS