SharePointCommunity
Die deutschsprachige Community für SharePoint, Office 365 und mit Azure

E-Mail Benachrichtigung funktioniert nicht

bewertet von 0 Usern
Nicht beantwortet Dieser Beitrag hat 0 Geprüfte Antworten | 2 Antworten | 1 Follower

Top-500-Beitragsschreiber
42 Beiträge
Andreas Order erstellt in 24 Feb 2018 13:45

Hallo,

ich habe unsere SharePoint 2013 Umgebung nach 2016 migriert, hat soweit alles wunderbar funktioniert. Das einzige was in der neuen Umgebung nicht funktioniert ist die E-Mailbenachrichtigung. Test-Mails kann ich über die SharePoint-Powershell verschicken, die Benachrichtigungsfunktion funktioniert nicht. Hat jemand eine Idee woran das noch liegen kann? In der alten funktionierte das noch.

Eckdaten:

Win Server 2016, SQL2016, SharePoint 2016 (alles aktuell), Virenscanner ist nicht installiert.

 

Neuer Hinweis: Wenn ich eine Benachrichtigung oboniere bekomme ich dazu eine E-Mail das die Benachrichtigung eingestellt wurde, aber wenn eine Änderung vorgenommen wurde bekomme ich trotzdem keine Mail, läuft das über einen speziellen Dienst?

Alle Antworten

Top-10-Beitragsschreiber
18.653 Beiträge

Das liegt auf jeden Fall am Mailsystem (welches?). Schaut Euch dort mal die Konfiguration für den alten SharePoint an und vergleicht sie mit der für den neuen.

Wenn man eine Benachrichtigung abonniert, wird eine Mail im Kontext des abonnierenden Benutzers verschickt. Wenn später eine Benachrichtigung verschickt wird, geschieht das im Kontext des Application Pool Accounts bzw. bei den Zusammenfassungen im Kontext des SharePoint Timer Service.

Viele Grüße
Andi
af @ evocom de
Blog
Top-500-Beitragsschreiber
42 Beiträge

Guten Morgen,

wir nutzen Exchange 2013. Wir haben eine Policy welche es erlaubt bestimmten Servern E-Mails ohen Authentifizierung im Domänennetzwerk zu versenden (nicht nach außen). In dieser Policy steht auch der neue SharePoint Server drin.

noch zur Info (ist aber wahrscheinlich nicht wichtig), Ich kann auch Bibliotheken mit meinem Adminaccount freigeben, welcher kein E-Mailkonto hat und die eingeladene Person bekommt direkt eine E-Mail im Kontex des Adminkontos.

Habe auch unter Sofortige Warnungen geschaut, hier werden alle 5 Minuten die Aufgaben ohne Fehler ausgeführt :-/

####

Lösung: 

Du hattest wirklich Recht, es lag am Exchange, obwohl das eigentlich alles richtig abgefangen wird. Habe gerade auch gelesen dass ich nicht der einzige bin und es da einen Workarround gibt: https://www.ccrossan.com/blog/microsoft-sharepoint/sharepoint-2016-outbound-smtp-failures/

Meine Lösung war es aber einfach dem Dienstkonto ein Exchangepostfach zu spendieren.

Seite 1 von 1 (3 Elemente) | RSS