SharePointCommunity
Die deutschsprachige Community für SharePoint 2016, 2013 und Office 365

Lösung lässt sich nicht aktivieren

bewertet von 0 Usern
Beantwortet (ungeprüft) Dieser Beitrag hat 0 Geprüfte Antworten | 4 Antworten | 2 Followers

Top-500-Beitragsschreiber
32 Beiträge
Steffi81 erstellt in 5 Mai 2017 11:33

Hallo zusammen,

bin gerade mal wieder am Verzweifeln! Mein Chef will neue Bereiche im SP angelegt haben. Dazu zählen 3 Collections mit diversen Unterwebseiten. Dafür habe ich eine Website-Vorlage erstellt (Website als Vorlage gespeichert, beinhaltet Bibs und Workflows), die auch bei 2 der 3 Collections ohne Probleme in den Lösungskatalog hochgeladen und aktiviert werden konnte und anschließend verwendet werden. Bei der 3. bekomme kann ich die .wsp Datei zwar in den Lösungskatalog hochladen, aber nicht aktivieren. Hier erscheint jedes Mal die Meldung "Fehler - Das hat leider nicht geklappt. Es ist ein unerwarteter Fehler aufgetreten." Ich habe auch schon die Features verglichen, kein Unterschied zu den anderen Collections.

Bitte um eure Hilfe, Cheffe wartet auf das Ergebnis.

Viele Grüße,

Steffi

Alle Antworten

Top-10-Beitragsschreiber
Männlich
17.807 Beiträge

Dann wurden die Site Collections wahrscheinlich mit unterschiedlichen Vorlagen und/oder unterschiedlichen Sprachen angelegt.

Übrigens ist das ein sehr schlechte Vorgehensweise. Die Solutions wird man dadurch nie wieder los und sie müssen auch für immer aktiviert bleiben. Sowas erschwert immer eine spätere Migration oder macht sie schlimmstenfalls sogar unmöglich.

Besser stellt man notwendige Inhaltstypen über den Inhaltstyp-Hub bereit. Die gesamte Infrastruktur wie Listen, Bibliotheken usw. kann man script-basiert anlegen. Der initiale Aufwand ist zwar größer, aber man eine saubere und vor allem dauerhafte Lösung.

Viele Grüße
Andi
af @ evocom de
Blog
Top-50-Beitragsschreiber
Männlich
291 Beiträge

Hmm. Schon mal in die Logs geschaut? (z.B. mit dem ULSVIewer live überprüfen wenn der Fehler kommt, was in den Logs steht)

Grundsätzlich sollte man aber aufpassen mit dem "Website als Template speicher" besonders wenn auch noch Workflows verwendet werden...

Sind alle SiteCollections auf dem selben Template entstanden?

SharePoint Enthusiast

Ich helfe gern, wenn es mein Zeit zu lässt :)
Gern auch per direkter Anfrage auf XING

Top-500-Beitragsschreiber
32 Beiträge

Dankesehr für eure schnellen Antworten!!

Die Seiten wurden alle mit der gleichen Vorlage und auch gleicher Sprache erstellt. Das Logfile hat leider auch kein Ergebnis gebracht.

Inzwischen habe ich das ganze  nochmal von vorne gemacht und aus einer Website, die mit meiner Vorlage erstellt wurde, nochmal eine Vorlage erstellt und diese dann in die "fehlerhafte" Collection hochgeladen. Das hat geklappt, ich konnte sie aktivieren und alles fertig erstellen.

Natürlich habt ihr mich jetzt seeeeehr verunsichert, was die Arbeit mit den templates angeht. Man muss dazu sagen, dass wir alle Plattformen, die wir intern anbieten (über 1000 Collections oder Seiten) mit Vorlagen erstellt haben.... Für Panik ist es da wohl schon fast zu spät :-(

 

 

Top-50-Beitragsschreiber
Männlich
291 Beiträge

Au weia XD

Wieviel Solutions sind das dann.....

Der große Nachteil von den SOlutions ist neben der Migrationsblockade auch das fehlen von Berechtigungsstrukturen.... ganz zu schweigen von den Metadaten / Inhaltstypen-Themen....

 

Für sowas würde ich immer mithilfe des vorgeschlagenen Content-Type-Hubs arbeiten und den zentral verwalteten ManagedMetadata. Ein PowerShell-Script hilft bei der Anlage der Seiten und kann sogar direkt die notwendigen Rollen / Rechte vergeben :) Und bei 1000+ Seiten wäre das sicher ein vertretbarer aufwand gewesen.

Das Script könnte man sogar so bauen, das es Updates an die Seiten verteilt, was ein Template auch nicht kann... (z.B. eine weitere App für alle hinzufügen oder weitere Spalten / Inhaltstypen etc...).

SharePoint Enthusiast

Ich helfe gern, wenn es mein Zeit zu lässt :)
Gern auch per direkter Anfrage auf XING

Seite 1 von 1 (5 Elemente) | RSS