SharePointCommunity
Die deutschsprachige Community für SharePoint, Microsoft 365, Teams, Yammer und mit Azure

Mehrere Listenformular-Web Parts auf einer Website-Seite - "Zufälliges" Auftreten der Meldung "Element erfolgreich erstellt"

bewertet von 0 Usern
Nicht beantwortet Dieser Beitrag hat 0 Geprüfte Antworten | 1 Antwort | 2 Followers

Ohne Rang
6 Beiträge
PPWN erstellt in 24 Apr 2017 9:50

Ich habe auf einer Website-Seite mehrere Listenformular-Web Parts, jeweils für einen verschiedenen Inhaltstyp. Wenn ich ein Element erstelle, erscheint die Meldung "Element erfolgreich erstellt" bei dem zuletzt hinzugefügten Webpart, unabhängig davon, ob ich über dieses das Element hinzugefügt habe. Das ist für die User natürlich verwirrend. Hat jemand eine Idee wie ich dieses Problem lösen kann?

Alle Antworten

Top-25-Beitragsschreiber
367 Beiträge

Da müsste man jetzt in das verwendete Script schauen. Ich denke mal es wird einfach den Text an ein bestimmtes Element versuchen zu hängen. Da es in der Seite das Element aber scheinbar 3x gibt, wird es einfach ans letzte gehangen. Im "schlimmsten" Fall haben die Elemente der einzelnen Webparts sogar die gleichen ID's bekommen vom DisplayTemplate....

hier müsste man das Sender-Objekt vorher abfragen (also den "Add-Button" beim OnClick-Event) und dann davon ausgehend an das Parent-Element die Meldung hängen.... Quasi muss die Ajax-Funktion angepasst werden...

(hoffe ich hab das halbwegs verständlich erklärt XD)

SharePoint Enthusiast

Ich helfe gern, wenn es mein Zeit zu lässt :)
Gern auch per direkter Anfrage auf XING

Seite 1 von 1 (2 Elemente) | RSS