SharePointCommunity
Die deutschsprachige Community für SharePoint, Office 365 und mit Azure

Installieren einer neuen WebApplication via Powershell

bewertet von 0 Usern
Nicht beantwortet Dieser Beitrag hat 0 Geprüfte Antworten | 3 Antworten | 2 Followers

Top-50-Beitragsschreiber
269 Beiträge
MStel erstellt in 16 Apr 2015 15:08

Hallo,

aktuell bin ich am erstellen einer neuen WebApplication über PowerShell.

Komme aber mit den Parametern nicht ganz klar.
Ich habe keine WWW- Domain, sprich ich würde die WebApplication auf meinem Lokalem Rechner ( Localhost ) erstellen. Von Hand klappte das ganz gut ich habe nun eine WebApp unter der Seite Localhost:36499 erstellen können.
Über Skript brauche ich dasselbe mit anderem Port. Dieser ist zwar als Parameter einfach mitzugeben, aber ich weiß den Rest nicht auszufüllen und/oder kann damit nichts anfangen ( Host Header, ApplicationPool { muss ein neuer erstellt werden dafür ? } , authentification Provider, oder auch der SecureSocket. )

Hier das Beispiel von Microsoft:

New-SPWebApplication -Name "Contoso Internet Site" -Port 443 -HostHeader sharepoint.contoso.com -URL "https://www.contoso.com " -ApplicationPool "ContosoAppPool" -ApplicationPoolAccount (Get-SPManagedAccount "DOMAIN\jdoe") -AuthenticationProvider $ap -SecureSocketsLayer

habe dieses Beispiel auf meine Daten angepasst und als Admin in der Shell laufen lassen und erhalte die Meldung "aus dem bereitgestelltem Parameter "pipebind"  konnte kein gültiges SP-webApplication Objekt erstellt werden"

Danke
Mstel

Alle Antworten

Top-10-Beitragsschreiber
592 Beiträge

Hi,

dein Beispiel verwendet Get-SPManagedAccount (bei dem du vermutlich einen anderen Parameter verwendest). Gibt es diesen Benutzer in deiner Farm? Wenn nicht, dann muss er zuerst angelegt werden (New-SPManagedAccount (https://technet.microsoft.com/en-us/library/ff607831.aspx)).

VG

Olaf

 

Top-50-Beitragsschreiber
269 Beiträge

Hi,

ich habe die benötigten Variablen nun mal alle erstellt und zugewiesen.
Was nun total keinen Sinn ergibt, ist dass ich für das Erstellen einer WebApplication eine ContentDB mitliefern muss.
Möchte ich allerdings eine Content Db erstellen, muss ich die WebApp dazu angeben.

Irgendwie bin ich gerade in einem Teufelskreis.

Top-10-Beitragsschreiber
18.754 Beiträge

Etwas verspätete Antwort, aber falls das Problem noch besteht einfach die ContentDB als String angeben. Es wird dann eine neue Datenbank mit diesem Namen angelegt. Jede WebApp braucht mindestens eine eigene ContentDB.

Viele Grüße
Andi
af @ evocom de
Blog
Seite 1 von 1 (4 Elemente) | RSS